peteg's blog

Casablanca

/noise/movies | Link

As good as ever. Can't believe I haven't seen this in five years.

Multiplexing conundrum

/hacking/nixie_clock | Link

I constructed a further three anode switchers and they work fine. Now I'm up to wiring in the nixie tubes, but as I only want to do this once, I'm getting a bit ginger. My concern is that the multiplexing setup I'm using, which is essentially what everyone seems to use, allows more than one tube to be on at a time. So in the worst case the poor K155ИД1 chip would have to pass approx 12mA (four tubes at 3mA each), which exceeds its rated 7mA.

From the software I've found, no-one seems to do anything clever, so I expect their microcontrollers get into the main scanning loop quickly enough that nothing blows up. Unfortunately the ts7260 takes several seconds to boot Linux, with the boot loader delaying three seconds for recovery purposes, so I don't think I can ignore this.

According to the ep9301 ARM chip specs, the ts7260 is supposed to configure all these GPIO pins as inputs on bootup, which leaves them floating. This is probably safe from the chip's point of view, but not the nixie board's.

A solution is to pepper the anode drivers with pull-down resistors on the bases of the buffer transistors (the MPSA42s). Ha! That's what this guy was doing. Hmm, perhaps everyone does it. :-) I'm using 33kΩ which seems to do the trick. The voltage drop across the series 33kΩ (between the ARM and the buffer transistor) increased from 1.7v to 2.3v, so the current for a logic-high has gone up to about 70μA, if I've done my sums correctly. That seems barely plausible.

This still leaves the circuit at the mercy of the software. A complementary approach is to gate the high tension, which I'll investigate doing when John Taylor's power supply turns up. I want to switch the nixies off under software control anyway.